Dark Age of Camelot Wiki
Advertisement
I am having problems patching Catacombs.

After installing your Catacombs client (but before patching), please feel free to download and install the Pre-Patch Install file from [1]

After downloading and installing the Pre-Patch Install file, please run the Catacombs client to patch up and play. Downloading this file directly will save you the time of using the Catacombs patcher to download the files and should allow you to get in the game faster.

Advertisement